PDA

View Full Version : broken off oil pressure sender?? HELP FAST!



Moody Blu'
08-20-2015, 10:51 AM
I'm not sure if what i see at the bottom of the oil passage for the oil sender units is suppose to be there or not it looks like the end piece of a oil pressure sender even has a dimple which you can make out slightly in the picture and it fell off? I'm not sure though. whatever the case is, before the brass fitting broke off the oil pressure gauge was reading fine I had only conencted one oil pressure sender to the wire and it seems that certain oil pressure senders require two senders one is a dummy and one is the actual. I had reconnected both senders and switched the wires to see if i had them wrong and i still get no reading on the gauge. I did put teflon on all the brass fittings when i reinstalled them and I realised i may have not been grounding it. Right now I am waiting for a friend to come over to see if we can pick the supposedly broken piece of a sender out of the hole. I am not sure it is suppose to be there or it is and im just worried.

please let me know if this looks like its normal for this 1979 high nickel block or is it not suppose tobe there? its the shiny metal with the black ring around it it really does look like a oil pressure sender piece fell in there but before the brass fitting broke the oil pressure worked fine so im a little stumbled if that is suppose to be there or not.

http://i35.photobucket.com/albums/d194/beerock69/WP_20150820_09_13_47_Pro__highres_zpsy7g57fvb.jpg (http://s35.photobucket.com/user/beerock69/media/WP_20150820_09_13_47_Pro__highres_zpsy7g57fvb.jpg. html)

Moody Blu'
08-20-2015, 11:03 AM
is this what im possibly looking at?

http://i35.photobucket.com/albums/d194/beerock69/OIL_PASSAGE_AND_PLUG_LOCATION_UNDER_REAR_MAIN_CAP1 _zps99cbsxag.jpg (http://s35.photobucket.com/user/beerock69/media/OIL_PASSAGE_AND_PLUG_LOCATION_UNDER_REAR_MAIN_CAP1 _zps99cbsxag.jpg.html)

Moody Blu'
08-20-2015, 01:31 PM
either sender or gauge took a crap bought a mechanical and mounted it so i have one ther eincase any electronic gauges go bad gonna get a water temp and oil temp soon

http://i35.photobucket.com/albums/d194/beerock69/WP_20150820_13_03_31_Pro_zpskyab6n8n.jpg (http://s35.photobucket.com/user/beerock69/media/WP_20150820_13_03_31_Pro_zpskyab6n8n.jpg.html)