PDA

View Full Version : Another Fueling Question



RedDog
09-20-2012, 01:19 PM
The whistler vent prompts me to ask another question.

More times than not I get a geyser of fuel while filling up. Happens before the tank is full and even happens if I try to fill more slowly. Anyone else have this problem and any solutions?

VetteLT193
09-20-2012, 01:31 PM
Is your vent working? If you have center fill you'll need help looking but it should be obvious if it is... you should hear it and you can see the fumes come out of it.

biggiefl
09-20-2012, 01:37 PM
I don't stand on the starboard side when fueling on the trailer. That vent is a LOT lower than the fuel fill and will flow before the gas shuts off. I find if I fill fast, it does it less often and I never try and top it off, she is within a gallon. If you fill at a marina, get one of the catch cups. Cops see you flow and you don't want to know.....

Tidbart
09-20-2012, 01:50 PM
I had that issue happen to me in my 22 once. At a local gas station, I started to fill an empty tank and a short time later, the fill tube hiccuped fuel all over the deck. I obviously stopped filling for a short period of time. I restarted slowly and it didn't reoccur. Hasn't happened since. Still a mystery to me.:bonk:

B

BUIZILLA
09-20-2012, 02:01 PM
post a pic of what your vent hose looks like under the deck

RedDog
09-20-2012, 03:01 PM
Pics attached. Vent runs straight up to underside of the deck and then turns down to the vent.

The vent is not clogged - vapors a come out when fueling and if I fill to much fuel will come out of it

roadtrip se
09-20-2012, 03:31 PM
Tim, if it helps, my vent hose has a complete loopy-to-loop on the way up to the vent connection. Your's only looks like a partial loop from the pics. I don't have a problem with burping.

RedDog
09-20-2012, 08:46 PM
[ QUOTE=$originalposter]{$pagetext}[/QUOTE]

Seems like a complete loop would make it more prone to burping?

dsparis
09-21-2012, 09:32 AM
Mine has a complete loop of clear hose so you can see if anything is in there.

RedDog
09-21-2012, 10:08 AM
I'm not getting water in, tried a check valve, and the line is clear with no debris - it vents

VetteLT193
09-21-2012, 10:45 AM
My only other thought is something is partially blocking the fill tube. I think there is something down there from the factory because I wasn't able to get a hose down my brother's 22 or my old Minx. Maybe there is a blockage with whatever is down there so it's filling up the fill tube then slowly draining in, kinda like filling up a funnel.