PDA

View Full Version : Need info on fuel pump or related switches/electro



Stevo440
05-24-2012, 03:14 PM
I posted 2 weeks ago that I thought I needed a new fuel pump for a 2001 454 Mag MPI. It all started when I was returning to the boat from having lunch at the restaurant on the lake and it took a long time to get the boat running. It would start then fizzle out, over and over again. Then it finally caught and ran so I headed back towards the ramp. I stopped about a mile or so from the ramp and alas when I went to start it it would not run. It would start then fizzle out and stop, it never caught this time, so I got a tow back to the ramp. The other day I went out to take it all apart, after looking up the info to replace it and seeing where it is located. I had someone turn the key and I was listening to the box to hear the pump and it seemed to be working. I then checked the filter that I had emptied when the problem had surfaced and it was full, so I started the engine and it ran fine on the trailer. I then proceeded to take the boat to the lake and ran it for 2hrs straight and it ran fine, top end, low end and everywhere in between. The one thing I did not do was shut it off this time while out on the lake, I just kept it running the whole time. So my question is, is it the pump or a switch or some other electrical device? Or is it hit or miss, replace it and cross my fingers? Any info is appreciated.

Thanks
Steve

MOP
05-24-2012, 09:13 PM
You may have a sticky safty switch, we have sold a few out this spring.

Stevo440
06-01-2012, 02:49 AM
Thanks for the reply. I took it out again and it started and ran fine. I did not shut it down, so I guess next time I will have to run it then turn it off and try starting it up again and see what happens.