PDA

View Full Version : Corsa performance Exhaust



flxwhaler
05-23-2011, 09:48 PM
This past winter I purchased a 1995 Classic 16 4.3 L V6. The boat is mint. It has been meticulously maintained. I put it in the water yesterday and ran it flawlessly with the open headers. Today, when I ran it the silent choice solenoid switch would not engage for the thru-hull corsa exhaust. Both solenoids would not crap out at the same time. I picked my way through with a voltage meter. I think the pull switch is good as there was no voltage to the switch; which tells me there is probably an in-line fuse somewhere in the wiring. Is there an in-line fuse somewhere between the battery and the switch?? I am stumped. Any suggestions on how to approach this? Any help is greatly appreciated!!

mrfixxall
05-23-2011, 10:37 PM
This past winter I purchased a 1995 Classic 16 4.3 L V6. The boat is mint. It has been meticulously maintained. I put it in the water yesterday and ran it flawlessly with the open headers. Today, when I ran it the silent choice solenoid switch would not engage for the thru-hull corsa exhaust. Both solenoids would not crap out at the same time. I picked my way through with a voltage meter. I think the pull switch is good as there was no voltage to the switch; which tells me there is probably an in-line fuse somewhere in the wiring. Is there an in-line fuse somewhere between the battery and the switch?? I am stumped. Any suggestions on how to approach this? Any help is greatly appreciated!!


follow the wires from the solenoids to the black box which is the reley pack,theirs usually a circuit breaker on that pack..also make sure the + - wirea are hooked up,some techs run the wires to the battery and when you hook up the battery you somtimes forget that they are their..

flxwhaler
05-24-2011, 06:18 AM
Thanks Fixx. The relay pack. would that be in the engine compartment or the battery compartment. Thanks

cgentile
05-24-2011, 02:41 PM
I have a 1994 4.3 with the same corsa system .. If you have a video of it running would love to see it and hear, it to see if it sounds the same as mine.

Also i believe if you throw the switch pass 2500 rpms it will trip the breaker to prevent issues ... from doing damage exhaust under high speed runs .


c gentile
Toronto.

flxwhaler
05-24-2011, 09:06 PM
Thanks you guys! Turns out it was a loose wire at the key switch. The key housing was loose and it twisted one wire out of a crimped connector. I spliced it back together. Man you have to be a contortionist to get under the dash and work. In terms of the sound of the V6 with corsa exhausts, there are several videos on youtube of the same vintage classic 16's which will give you a good comparative analysis in terms of the sound. I would not say it is loud by any means. A healthy rumble nonetheless. Still learning how to drive the thing--been playing with the tabs. Gonna take some seat time to become proficient. Overall I am very pleased with the boat. The prior owner was meticulous--as most Donzi owners are. I lucked out. Thanks Donzi Doug!!
-Whaler out