PDA

View Full Version : New Livorsi GPS Hardwired Receiver - butt ugly!!



Selenium
05-18-2011, 02:31 PM
http://www.livorsi.com/catalog/gps_antenna.htm

I just had this installed....what you guys think? I think they could have design it way better:

1. wiring should be coming from the bottom NOT the side.
2. Hockey Puck looks way better.
3. has a little tab on one end to screw down the unit (but my guy used double-sided tape)

This thing is butt-ugly nothing pretty about it.

Conquistador_del_mar
05-18-2011, 02:34 PM
http://www.livorsi.com/catalog/gps_antenna.htm

I just had this installed....what you guys think? I think they could have design it way better:

1. wiring should be coming from the bottom NOT the side.
2. Hockey Puck looks way better.
3. has a little tab on one end to screw down the unit (but my guy used double-sided tape)

This thing is butt-ugly nothing pretty about it.

I mounted mine under the dash so it wouldn't show. Bill

Carl C
05-18-2011, 02:36 PM
Hate to say it but I agree. I haven't been too impressed with Livorsi products.

Selenium
05-18-2011, 02:41 PM
Hate to say it but I agree. I haven't been too impressed with Livorsi products.

At least I know how fast I'm going now....maybe I should put a bucket over it ;-)

CHACHI
05-18-2011, 06:34 PM
I mounted mine under the dash so it wouldn't show. Bill

+2, I have the hockey puck version and there is no issues with receiving the signal under the fore deck.

Ken

JustMercMe
05-18-2011, 06:49 PM
Livorsi in my book has dropped the ball on this receiver issue. Mine gauge is still stuck on 50 mph b/c i refuse to pay another $200 for a part that they should be replacing. Hell I even noticed the finish on my bezels corroding up......Total crap for the money you spend on it.

Just my 2 cents.

Selenium
05-18-2011, 06:55 PM
Livorsi in my book has dropped the ball on this receiver issue. Mine gauge is still stuck on 50 mph b/c i refuse to pay another $200 for a part that they should be replacing. Hell I even noticed the finish on my bezels corroding up......Total crap for the money you spend on it.

Just my 2 cents.

You are right, I spent 180 + 30 recalibrate + shipping.