PDA

View Full Version : freshwaterflush



margo
09-26-2010, 08:48 PM
I have the fitting on my transom for a fresh water flush setup...Previous owner unhooked it when installing a crate engine..Never hooked it up on new engine..Nothing there except the fitting...Where do i run the hose to rehook it up?? Can you winterize through this setup? Thanks Joe

VetteLT193
09-27-2010, 02:49 PM
all you need to do is T it into the raw water hose that runs from the drive before the water pump.

If you still have the alpha pump setup in the drive then leave it unhooked.

margo
09-27-2010, 10:19 PM
Thanks i do have the pump setup, just replaced the impeller

farmer tx
09-27-2010, 11:50 PM
This is what you need.

http://www.amazon.com/Perko-0456DP7-Marine-Flush-Valve/dp/B00144D86Y

You also need one of these, can't remember what size barb is on the thru hull fitting. Connect the thru hull to the side fitting on the flush.

http://www.westmarine.com/webapp/wcs/stores/servlet/Product_11151_10001_105348_-1?cid=chanintel_google&ci_src=14110944&ci_sku=105348

If it's an alpha drive you still have to use muffs.

VetteLT193
09-28-2010, 08:14 AM
Thanks i do have the pump setup, just replaced the impeller

With the pump in the drive the impeller will burn out quickly if you use the hookup.

on a related note, if you use the hookup you need to make sure the cap is screwed in place at all times when running the boat or it will either suck in air or blow out water depending on setup.

margo
09-28-2010, 08:47 PM
With the pump in the drive the impeller will burn out quickly if you use the hookup.

on a related note, if you use the hookup you need to make sure the cap is screwed in place at all times when running the boat or it will either suck in air or blow out water depending on setup.
Thanx everyone i think i will leave well enough alone and just use the muffs...In fresh water only