PDA

View Full Version : New "Sweetie" Owner



damarjos
08-18-2010, 08:01 PM
Hi all,

Just bought my first Donzi Sweet 16 about a month ago and I'm having a blast with her, but I had a couple of questions for the experts. I am having a small issue with the power trim...works fine going up, but takes a long time to go down (I'm sure there's a joke in there somewhere). I looked at the fluid reservoir and it looks low so I bought some fluid to put in this weekend. Just wondering if I'm too optimistic that this is the issue. Secondly, she's white with yellow stripes and the yellow is quite faded. I'm going to try some 3M rubbing compound this weekend, but wondered if the ultimate approach is to repaint her. Any suggestions?

Just Say N20
08-18-2010, 09:59 PM
Welcome. White and yellow. That is the color combo I chose to paint my 16.

I don't know what to tell you about the trim. Someone will chime in.

I have seen some pretty amazing "back to life" stories with gelcoat that looked pretty bad. I would do a search for gelcoat, polishing, wet sanding, and you should fine a lot of documentation regarding this.

Be careful on the "corners" of the gel, as those areas are easy to go through.

Unless it has had a lot of wet sanding prior to your ownership, I would think you should be able to bring it back. Worst case scenario would be wet sanding the whole hull (800, 1000, 1500), and the buffing it out, and then getting several coats of wax on it.

I think you will be surprised at some of the results people have gotten.

Ranman
08-18-2010, 11:44 PM
I recently had a similar issue with my trim on a Bravo drive. The drive would go up OK, but would not go down well. In my case it turned out to be a bad trim ram (both actually had issues, but one was way worse).