PDA

View Full Version : 2001 28' ZX Twin Eng Steering issues



stationinc
06-06-2010, 08:27 PM
When running with eng trims down, no problem
Once I start trimming out from 25 to 35mph, steering gets very loose ( boat will do a 60 to 70o turn in a split second ), & almost feels like air in the steering lines or nothing their @ all
It only get loose when I try and adjust the trims up

Couple of things:

Has standard Donzi steering
Anyone had this issue & how did you correct it ??????
Should there be any play in the trims, I can move side to side very easy & has no wheel turn @ all
There is a little play in the wheel also & I do have a steering line that is leaking, will repair on Mon
But there is so much play, I wouldn't think that would be the problem ????


1sr season with the boat
I do not have the past history of this boat, so I do not know if this has been a lond standing issue
Love the boat but can't operate it like this ( not safe )
Help
stationinc

MOP
06-06-2010, 09:51 PM
If the steering is tight with no play at slower speeds, I think you may be over trimming.

mrfixxall
06-06-2010, 09:59 PM
from what you describe it sounds like you have hydraulic steering which has trim looking cylinders as you describe..you probably have a leak and you will need to find that leak asap!! than you will need to add fluid and bleed the lines..

need a pic of the back of your boat

Trueser
06-06-2010, 11:07 PM
When running with eng trims down, no problem
Once I start trimming out from 25 to 35mph, steering gets very loose ( boat will do a 60 to 70o turn in a split second ), & almost feels like air in the steering lines or nothing their @ all
It only get loose when I try and adjust the trims up

Couple of things:

Has standard Donzi steering
Anyone had this issue & how did you correct it ??????
Should there be any play in the trims, I can move side to side very easy & has no wheel turn @ all
There is a little play in the wheel also & I do have a steering line that is leaking, will repair on Mon
But there is so much play, I wouldn't think that would be the problem ????


1sr season with the boat
I do not have the past history of this boat, so I do not know if this has been a lond standing issue
Love the boat but can't operate it like this ( not safe )
Help
stationinc


system needs to be bled.... You have air in the rams.

LKSD
06-07-2010, 05:07 AM
Try having the system bled first & also make sure you are not giving too much trim and or breaking the props loose..

VetteLT193
06-07-2010, 07:53 AM
The first thing is do you have Hydraulic steering or not? That will have stainless rams externally mounted to the drive. A tie bar should be bolted between the two drives.

From what I read it sounds like you can move the drive back and forth by hand. That shouldn't ever happen.

stationinc
06-07-2010, 08:03 PM
Thanks for all of the feedback
I will keep you posted on the progress
Also
Forgot to mention
When the boat does a spin out
Always to the right
Not sure if that helps
Anyway

I would like to e-mail some of these feedbacks
PLease e-mail w/ yours

My e-mail address is as follows:
stationinc@aol.com